x86 or x64 – Really? Are you kidding?

While working on a VS2008 to VS2010  conversion, I kept running into a problem where MSBUILD would literally blow up. I narrowed it down to the building of a particular MSI using WXS v3.5.  I had a repo!  I knew I could solve this problem but after making multiple changes in the WXS and the WIXPROJ files I was still seeing the issue.  I finally backed up took a different approach.  I had installed the latest Votive so I knew I could build an empty Setup project.  After creating the dummy Setup project and building it successfully in the IDE I went back to the command line and ran via MSBUILD.  I got the error “The specified solution configuration “Debug|X64” is invalid.”.  What?  I new that Debug had to be valid, then if finally hit me.  WXS did not support X64!!!  Are you kidding me?  In our current world of multiple CPU, multiple core, X64 systems, our installer doesn’t support it?  Needless to say, I was disappointed but at least I had my solution: Run the non-X64 command line window.

This just goes to show you that the old adage of “Question everything” strongly applies when investigating issues.  When you start from a false assumption, it will only cost you time and effort.  Lesson RE-learned!

Happy Coding!

Advertisements
This entry was posted in Uncategorized. Bookmark the permalink.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s